FLASH Tech Tip - Java Web Start as of February 13, 2019

CustomerConnectionsTridium.png

As previously communicated by Triidum, Oracle has announced the pending end-of-life of Java SE 8 (Standard Edition). As of January 2019, free public updates are no longer available. Customers accessing Niagara with the Java Applet/Web Start will be impacted by this change. Those who have upgraded to full HTML5 versions for their browser front-end will not be affected. For customers who use the Java VM and Java Web Start for their legacy systems, Tridium is actively developing a suitable alternative.  

UPDATE: Starting with the April 2019 scheduled quarterly critical patch update from Oracle, Commercial Users will have access to updates through My Oracle Support for their Java Applet/Web Start. Or users can begin utilizing the Niagara alternative, Niagara Web Launcher, which is currently scheduled to be available in mid-March.   


Please review this video to get a better understanding of what to expect. 

To assist in understanding the potential impact to your system, please review the FAQ section below. 

Warning message displayed when installing a Java Update:

Java8Jan19Update.png

Frequently Asked Questions:

Q: Will my system stop working?
A: No, your application will continue to work as long as you have your Java Run-Time Engine (JRE) installed. However, you will not receive future security updates after the January 2019 update.

Q: Does this affect Niagara Workbench?
A: No, this does not affect Workbench users.

Q: Does this affect my Niagara Supervisor or JACE?
A: No, Tridium is still providing security updates for these platforms.

Q: Does this affect the web browser I use to access my Niagara system?
A: Yes, this impacts the JRE used in your browser if you are still using Java based views.

Q: Do I need to upgrade my installed version of Java?
A: Our replacement product will not use the version of Java currently installed on your system. Tridium will provide an up-to-date version for use by our application. Please consult with your IT department about updating your locally installed version as changes may impact products from other vendors. 

Q: Which version of Java does the Niagara Web Launcher support?
A: Java 8


Q: Will there be a cost for this new application? 

A: At this time, there will not be a cost for this new application. This is subject to change.

Q: Which versions are supported?
A: AX 3.8 and forward; Niagara 4.4u1 and forward.

Q: Will I have to make changes to my applications?
A: Yes, you will need to update certain modules to provide end users with an application download and start-up link. More information will be provided once the alternative is available.

Q: How will I get the Niagara Web Launcher?
A: Contact your Niagara partner to get the appropriate JAR files.

Q: Will the JRE for Niagara Supervisor and JACEs still be Oracle J2SE?
A: The supervisor and JACE JRE will not be changed as a part of releasing the Niagara Web Launcher.

Q: Will there be some impact (specific bugs, performance, memory) in running two different JREs?
A: We do not expect any issues. 

For additional information from Oracle, check out the Java SE Support Roadmap and the Oracle Java SE 8 Release Notes